1 (edited by 2012-09-23 08:41:02)

Topic: Broken Comment Form

For some reason the comment function is broken on my website.
Note that  I have not modified the "Comment" or "Comment Form" templates at all.

The problems are:

1) Comment form is broken. As you can see from the image below, some characters appear before and after what should be your username and email. The textarea is not the correct size, and the Submit button is not there at all, so I'm not even able to test it.

http://imageshack.us/a/img703/8428/commentform.jpg

2) The comment form appears above the news. Maybe this the intended behaviour, but is there a way to change it? By appearing above the news, it completely breaks my website. I saw someone had made a hack that aparently lets you move it, but this was for an older version of cutenews so I can't use it.

Re: Broken Comment Form

Same problem!!
Someone knows how to fix it?

3 (edited by 2012-09-27 19:32:47)

Re: Broken Comment Form

also the same problem, just started an own thread minutes ago and now i have found this one... http://cutephp.com/forum/style_emoticons/default/wacko.gif

I have tried some things:

It definitely has something to do with editing templates. When I install cutenews it still works but when I edit the templates no matter what I change there its enough to save it without a chage the comment form gets broken. http://cutephp.com/forum/style_emoticons/default/sad.gif

Re: Broken Comment Form

Mugen Racer, did you get the comment form working? It seems to look OK on your website.
Could you tell how you got it working?

Re: Broken Comment Form

Seems to be a problem of the new beta version, I just "solved" by uploading the old CuteNews version

Re: Broken Comment Form

I thought about doing that too, but it is annoying having to use an older version when there is supposed to be a new and "improved" version..

Re: Broken Comment Form

So I downloaded (what I assume is) a newer version of 1.5 from here https://github.com/CuteNews/cute-news-repo/downloads (download zip) and installed this in a new location and set up my templates again.

This time the comment form looks a bit better - the Name and Email fields are fixed, but the textfield and submit button are still broken. It also appears below the news article as it should do.

Re: Broken Comment Form

So I downloaded (what I assume is) a newer version of 1.5 from here https://github.com/CuteNews/cute-news-repo/downloads (download zip) and installed this in a new location and set up my templates again.

This time the comment form looks a bit better - the Name and Email fields are fixed, but the textfield and submit button are still broken. It also appears below the news article as it should do.


you can fix that to edit your template via:      File: /public_html/cutenews/cdata/Default.tpl
and delete all "" then it works again.

._. It's an annoying problem.

Re: Broken Comment Form

Excellent, this fixed the problem! Thanks.

Not sure why, but even though every " in the whole template was \", it was only the comment and page pagination part that was broken..

Now for some reason the smiles are showing as "smile wink wassat" etc instead of the actual smiley.. but that's another problem..

Re: Broken Comment Form

Now for some reason the smiles are showing as "smile wink wassat" etc instead of the actual smiley.. but that's another problem..

Make sure that the emoticons are in the skins>emoticons directory. They used to be in the data directory but the migration tool does not move them.

11

Re: Broken Comment Form

Yup, they are where they should be. It's strange, I have installed CuteNews a bunch of times now in different places, and sometimes the emoticons show, and sometimes they don't...

Re: Broken Comment Form

You can find some answers here  http://cutephp.com/forum/index.php?show … 29&hl= .
Also it's just a beta version that is in the process of testing so these problems are still ok.

Best regards,
CN Support team