1 (edited by 2012-10-18 14:00:30)

Topic: Cutnews isn't working

Hi I'm using cutenews for about 2 year now and I love to work with it, but lately cutenews isn't working properly http://cutephp.com/forum/style_emoticons/default/sad.gif
So I decided to delete the whole cutenews map and re-install it, but then the problems really started.

For some reason cutenews refuses to be shown at my homepage see here. The page remains blank and I'm 100% sure that I'm using the correct codes, cause it was working before...
This is the code I'm using:

<?php
$number=5;
include("/home/vhosts/maikeboerdamfansite.nl/httpdocs/nieuws/show_news.php");
?>

Could someone please help me? I'm getting more and more frustrated by the minute.

Thanks in advance!

ps: Sorry if my grammar isn't that good, but I'm from the Netherlands

Re: Cutnews isn't working

Try a relative path instead of an absolute one
include("nieuws/show_news.php");

Re: Cutnews isn't working

Try a relative path instead of an absolute one
include("nieuws/show_news.php");

It''s working now! Thank you so much!

Re: Cutnews isn't working

ok it was working, but the page went blank again http://cutephp.com/forum/style_emoticons/default/sad.gif

The only thing I did was adding the lastest news and the trouble starts all over again. I don't understand what I'm doing wrong.
I went to cutenews, logged on, went to add news, typed my text and pressed add news. After that I went to my site refressed it and nothing! Even the news that was there is gone  http://cutephp.com/forum/style_emoticons/default/dry.gif

Re: Cutnews isn't working

I can see two articles on the main page just fine: "Maike te zien in Koffietijd" and "Problemen met nieuwsprogramma opgelost". Has the problem solved itself again or am I missing something?

Re: Cutnews isn't working

That's strange! After your post I opened the site in another browser (google chrome) and there the news is indeed visible, but if I open the site in the standard browser, which is Internet Explorer, then it's not visible...

Does anyone know how it is possible that the news isn't shown if the site is opened with Internet Explorer? Do I have to change something in my settings??

7 (edited by 2012-10-23 17:16:22)

Re: Cutnews isn't working

I did a quick check with IE7 and I can see the news just well, as well as with my standard browser, which is Firefox.

If a browser is not showing stuff another one is, it's likely that your HTML or CSS is causing some trouble. Browsers react differently to non-conform and even conform code (in regards to the standards). I looked at your HTML quickly and didn't find anything really bad; I think you may be missing a </div> but that shouldn't be too dramatic (het is geen wereldramp — as one would say in Dutch).

I'd suggest creating a new template and just adding something like:

<p>[b]{title}[/b]

{short-story}</p>


... for short story.

Change $template in your index.php to use that new template and look at it in your browser. If the news displays properly and it shows up, you can slowly start adding more HTML from your normal template over until it causes a problem. Then we know where to look for the problem.

I'd love to help further, e.g. if you find more precisely what bit of HTML is causing the problem.

Re: Cutnews isn't working

I think it has something to do with my version of IE (I'm using IE10), cause the news is displayed in Chrome now. I asked friends of mine who also have IE to take a look at the website and they can all see the news.

Thanks for you help anyway! http://cutephp.com/forum/style_emoticons/default/smile.gif