1 (edited by 2012-12-26 21:59:40)

Topic: CSRF is missing

Hello,

I'm sorry to bother you but I hope to be able to find help here.

I'm using CuteNews 1.5.0 which I downloaded from cutephp.com
The installation went alright, all permissions were set correctly, and apparently nothing went wrong.
However, when I logged out for the first time and tried to log in later on it reads Error (no further information) before I get redirected to the login form again, but it reads #csrf_is_missing in the address bar after the url where I installed CuteNews at.

I'm absolutely sure I didn't write either the password or username wrong.

I only changed files once following the instructions provided on the forum to add re-captcha.

I hope anybody has any idea how to solve the problem.

Please respond.

Re: CSRF is missing

Please explain what you did when you 'changed files once following the instructions provided on the forum to add re-captcha'.
CuteNews 1.5.0 has captcha built in. You should not need to change anything.

Re: CSRF is missing

Please explain what you did when you 'changed files once following the instructions provided on the forum to add re-captcha'.
CuteNews 1.5.0 has captcha built in. You should not need to change anything.

I followed this instruction : http://cutephp.com/forum/index.php?showtop...mp;#entry100322

I edited /inc/shows.inc.php and core/com/allow_comments.php (since searching for
$template_form = str_replace("{smilies}", $smilies_form, $template_form);
didn't show any results I continued to search in all documents)

I'll try change it back to the original files and see if that does the trick.

... No, still the same.

Re: CSRF is missing

This is not a Cutenews error. There is something you have not changed back. Check your template, upload new cutenews files. Remove all the recaptcha files.

5 (edited by 2013-01-30 07:27:41)

Re: CSRF is missing

Thanks for the informations! Really helped me out.

Re: CSRF is missing

This is not a Cutenews error. There is something you have not changed back. Check your template, upload new cutenews files. Remove all the recaptcha files.

I deleted all previous files and reuploaded the original files to install CuteNews again.
Since I activated the new Facebook plugin and it was showing in Russian, I edited some files according to github (https://github.com/CuteNews/cute-news-repo/commit/44cc22e10c983234a7b20a7f4b8275eaff01d8a3) which was recommended on another thread to a person who was facing the same problem with Facebook comments on CuteNews.

CuteNews is showing up properly, no errors in permissions, however, I still encounter the same problem when I try to login.
Password and username are written correctly, though.

Is there any way to see which line or which file exactly causes this error?