1 (edited by 2014-10-19 20:19:19)

Topic: upgrading from 1.4.6 to 2.0.2

I need to upgrade from 1.4.6 to 2.0.2 as my website is too large and the Search function is crashing. I would also like to take advantage of the additional features that CuteNews offers. The problem is that the documentation is difficult to understand. I have found "How to install or upgrade from 1.4x or 1.5x to v2.0" It is better than another document that I found that was almost unreadable.

I downloaded and unzipped 2.0.2 to a new folder on my own computer: Cutenews 2.0.2. I then deleted as advised, from my installed Cutenews on the host computer: the Inc and Skins  folders and also from the root folder Example 1.php and Example 2 .php. I didn't change the cdata folder (it doesn't exist on 1.4.6) or Uploads.

Next the advice paragraph 2 is as quoted: "then unpack the files stored in the zip to the place where the previous version of Cutenews was and update the administraor page. It's recommended to make Logout before updating Cutenews."

I copied all the files from my Cutenews 2.0.2 folder to the server's cutenews folder overwriting any folders that pre-existed. I was then able to create a new Administrator account and received a congratulations message. I had been logged out, or not even logged in! so the advice to Logout is wrong. I tried to login in order to logout  http://cutephp.com/forum/style_emoticons/default/smile.gif and my new password was rejected. That was the end of the upgrade for me.

Result, I am stuck, except I wiped cutenews 2.0.2 and reinstalled 1.4.6 from my home computer backup. So my website still works but I am unable to upgrade to 2.0.2. without some expert advice.

Can anyone explain what I did wrong. My websites are hosted on a Windows server. I would just like to add that I have used 1.4.6 for over 6 years and have had only a few problems that are probaly not due to Cutenews anway http://cutephp.com/forum/style_emoticons/default/smile.gif Visit My Website

Re: upgrading from 1.4.6 to 2.0.2

1. To migrate correctly from 1.4.6 to 2.0.2 you need to install version 2.0.2 alongside (!) version 1.4.6 without changing anything.
2. Create new admin account in version 2.0.2.
3. Go to Dashboard > Maintenance > Migration.
4. Choose Migrate from 1.4.Ñ…, indicate the path to the catalog where version 1.4.6 is installed, indicate the code where the news of version 1.4.6 are stored, indicate the files you want to transfer to the new version.
5. Click Do convert.
Check the results of the migration. If you have any problems with pagination, run the script  migration_update_indexes.php from the core folder in version 2.0.2.

Best regards,
CN Support team

Re: upgrading from 1.4.6 to 2.0.2

1. To migrate correctly from 1.4.6 to 2.0.2 you need to install version 2.0.2 alongside (!) version 1.4.6 without changing anything.
2. Create new admin account in version 2.0.2.
3. Go to Dashboard > Maintenance > Migration.
4. Choose Migrate from 1.4.Ñ…, indicate the path to the catalog where version 1.4.6 is installed, indicate the code where the news of version 1.4.6 are stored, indicate the files you want to transfer to the new version.
5. Click Do convert.
Check the results of the migration. If you have any problems with pagination, run the script  migration_update_indexes.php from the core folder in version 2.0.2.

Thanks.

I have created a new folder for cutenews. I named it cutenews202. I have uploaded 2.0.2 to the new folder. (Step one has been completed) I then created an admin account successfully. I then selected Start using cutenews. I was then presented with  another login window but was unable to login receiving an error message: invalid password or user name.

I have used the same admin user name and password as I used for 1.4.6 but this should not make any difference. I have tried the lost password option but the result is a message: user does not exist!

Re: upgrading from 1.4.6 to 2.0.2

Thanks.

I have created a new folder for cutenews. I named it cutenews202. I have uploaded 2.0.2 to the new folder. (Step one has been completed) I then created an admin account successfully. I then selected Start using cutenews. I was then presented with  another login window but was unable to login receiving an error message: invalid password or user name.

I have used the same admin user name and password as I used for 1.4.6 but this should not make any difference. I have tried the lost password option but the result is a message: user does not exist!

Can anyone help me with this issue. The website is hosted on a Windows server, if that makes any difference.

Re: upgrading from 1.4.6 to 2.0.2

Can anyone help me with this issue. The website is hosted on a Windows server, if that makes any difference.


You need to delete the users.txt file in the cdata folder and all files in the users folder. Then you need to perform reinstall and enter your login and password correctly, in Latin letters.

Best regards,
CN Support team

Re: upgrading from 1.4.6 to 2.0.2

You need to delete the users.txt file in the cdata folder and all files in the users folder. Then you need to perform reinstall and enter your login and password correctly, in Latin letters.

Thanks I have tried that. I still get invalid password or user.  Should I delete the conf.php.....bak files as well?

7 (edited by 2014-11-04 12:36:14)

Re: upgrading from 1.4.6 to 2.0.2

Thanks I have tried that. I still get invalid password or user.  Should I delete the conf.php.....bak files as well?

I really need to be able to get my website up and running on the new version of Cutenews. The current version is running under php 5.2.6 should this be updated? Also should I move the website to a Linux server?

Re: upgrading from 1.4.6 to 2.0.2

I really need to be able to get my website up and running on the new version of Cutenews. The current version is running under php 5.2.6 should this be updated? Also should I move the website to a Linux server?


If your .bak files start to appear, it means that writing to the users.txt files is unavailable and the user cannot be created correctly.  You need to check write permissions in the cdata folder and particularly in the users.txt file for the username that runs your website.

Best regards,
CN Support team

9 (edited by 2014-11-10 19:28:35)

Re: upgrading from 1.4.6 to 2.0.2

If your .bak files start to appear, it means that writing to the users.txt files is unavailable and the user cannot be created correctly.  You need to check write permissions in the cdata folder and particularly in the users.txt file for the username that runs your website.

This is the link to the current installation instructions Cutenews installation either this is correct or it is not. Please confirm.  Unfortunately, I do not understand it.  What I have done is managed to run the install Cutenews. Permission Check (check writeable dirs) displays 7 directories as being OK. The list is:<ol type='1'> * cdata
* uploads
* cdata/news
* cdata/plugins
* cdata/btree
* cdata/backup
* cdata/log
</ol>

I have rwx for me as owner for all files.  I am still getting Invalid User or wrong password. Do I need to be logged in to the website on the server while I access the install module using my browser?

Thanks

Re: upgrading from 1.4.6 to 2.0.2

ggeoff
The migration instructions are correct. If there's nothing wrong with your access rights, then you should encounter no problems. You don't have to access the website during the installation of CuteNews.
Try reinstalling CuteNews.

Best regards,
CN Support team