26 (edited by 2014-04-28 08:02:32)

Re: 2.0.1 pagination not displaying

Dear Users!

We've tested the issue with a few installation variants of CuteNews 2.0.1, still we cannot reproduce the problem.

It has been stated that only v.2.0.1 has this flaw. Could you kindly provide the following information concerning the problem: your local server configuration, your browser and OS, the encoding used on your site and kindly attach the cdata/conf.php file.

Best regards,
CN Support team

27 (edited by 2014-05-04 03:45:46)

Re: 2.0.1 pagination not displaying

Hey Support Team...

Where is $rs['overall'] defined? Can't find is anywhere on the files... There is a chance that I missed it....
But it tells the script if the pagination is showed or not, so...

// Count showed rows
$_cn = $rs['overall'];

// No pagination, if showed rows less than number
if ($_cn <= $number || !$number)   
 $_enable_pagination = FALSE;

28

Re: 2.0.1 pagination not displaying

Well... Someone might want to try this:
in includes/active_news.php change

$_cn = $rs['overall'];

to

$_cn = $rev['overall'];

Might work, might not.

Re: 2.0.1 pagination not displaying

Hello...

i have the same problem with pragnation on 2.0.1..

Still testing on a Local Sytem, do an update from 1.4.6, running xampp182 (Apache/2.4.7 (Win32) OpenSSL/0.9.8y PHP/5.4.25)
Imported 16 News.

The fix from "Ifa" doens't work :-(

30 (edited by 2014-05-05 07:23:44)

Re: 2.0.1 pagination not displaying

Where is $rs['overall'] defined? Can't find is anywhere on the files... There is a chance that I missed it....


$rs['overall']  is defined in modules/core.php (function cn_get_news).

Best regards,
CN Support team

Re: 2.0.1 pagination not displaying

Hello...

i have the same problem with pragnation on 2.0.1..

Still testing on a Local Sytem, do an update from 1.4.6, running xampp182 (Apache/2.4.7 (Win32) OpenSSL/0.9.8y PHP/5.4.25)
Imported 16 News.

The fix from "Ifa" doens't work :-(


After migration news in dashboard you should execute migration_update_indexes.php. It's restore indexes and pagination correctly recalculate.

Best regards,
CN Support team

Re: 2.0.1 pagination not displaying

Hello everybody,
I'm new to Cutenews so I don't know if this is a new issue that didn't appear in older versions. I've done in my website, still in localhost, the following include from cutenews.// No pagination, if showed rows less than number
if ($_cn <= $number || !$number)   
$_enable_pagination = FALSE;
Thanks for your sharing ! that is a good news to me . If you want to find more information about matériel dentaire ,you can visit my site http://www.athenadental.fr/.

Re: 2.0.1 pagination not displaying

I think the code works. It must be an issue due to the server's configuration or the php version the server uses. I did experience the bug while working on localhost, using wamp, but when I did a test on a live server the pagination worked just fine. I suggest everyone who is having this problem to try different servers.

Re: 2.0.1 pagination not displaying

After migration news in dashboard you should execute migration_update_indexes.php. It's restore indexes and pagination correctly recalculate.


Don't help :-(

Seems, that no changes on indexes...

Re: 2.0.1 pagination not displaying


i think, an update from 1.46 to 2.01 have many bugs ....


now, i make a clean install, enter the news manually in Cutenews (copy form 1.46) an saved then...

Pragnation is now showing !!

http://cutephp.com/forum/style_emoticons/default/biggrin.gif

Re: 2.0.1 pagination not displaying

Dear Users!

We've tested the issue with a few installation variants of CuteNews 2.0.1, still we cannot reproduce the problem.

It has been stated that only v.2.0.1 has this flaw. Could you kindly provide the following information concerning the problem: your local server configuration, your browser and OS, the encoding used on your site and kindly attach the cdata/conf.php file.

Hello, I am having the same issue with the pagination.

I'm using a localhost on my PC, with latest wamp running, I already tried in Chrome, IE and Firefox on windows 8.1, in any of them the pagination had worked.

It's a kind sad, because it is the best news system that I found.

Re: 2.0.1 pagination not displaying

yokesi wrote:

Hello everybody,

I'm new to Cutenews so I don't know if this is a new issue that didn't appear in older versions. I've done in my website, still in localhost, the following include from cutenews:

<?php /*Here we decide what page to include*/ happy wheels

if ($_GET['search']){
include ("blog/search.php");
}
elseif ($_GET['do'] == 'archives'){
include ("blog/show_archives.php");
}
elseif ($_GET['do'] == "stats"){
echo "You can download the stats addon and include it here to show how many news, comments ... you have";
// include("$path/stats.php");
}
else{
$template = "my_template";
$number = 3;
include("blog/show_news.php");
}
?>

In my browser the posts display correctly using the layout I've designed in "my_template". As you can see I've choosen to show only 3 posts per page but there are more of them so I expect to see pagination controls (prev, ext, etc) beeing displayed somewhere in the page . The problem is that they aren't. They aren't displayed even using default template.
I don't know if I have to add some extra line of coding to achieve this, include pagination somehow or if I'm missing something. Does someone have any idea of what's happening? Thanks.

The template should have a Pagination tab containing

<p align="center">[prev-link]<< Previous[/prev-link] {pages} [next-link]Next >>[/next-link]</p>

Also check System Configuration/News and make sure Pagination is not disabled.
It did not work for me (v2.0.1) - when the Next arrow was clicked, it just refreshed the page without showing the next page of items.

Likewise there is an issue with the Comments section in V2.0.1 which I have tried to draw attention of the script authors to in a separate post.